lights FAQ Forum github.com/luapower/openssl

openssl

OpenSSL binding for LuaJIT


Overview

Package type:Lua+ffi
Version:43e41fe
Last commit:8 months ago
Releases: None yet.
Platforms:

Dependencies   This is a combined list of packages required by all modules of this
package on each supported platform, plus binary dependencies if any.
Darker names, if present, represent indirect dependencies.
Purlpe names, if present, represent packages that contain modules that must be already be loaded.

Note: These are only the dependencies required for the modules to load.
Runtime dependencies, if any, are shown separately below.

Tip: You may not need all the dependencies listed here if you are not planning
to use all the modules of the package -- look at per-module dependencies below.
 

Modules     P M

module   language
libcrypto Lua
luajit 
libcrypto_asn1_h Lua
luajit 
libcrypto_bio_h Lua
luajit 
libcrypto_bn_h Lua
luajit 
libcrypto_buffer_h Lua
luajit 
libcrypto_conf_h Lua
luajit 
libcrypto_dh_h Lua
luajit 
libcrypto_dsa_h Lua
luajit 
libcrypto_ec_h Lua
luajit 
libcrypto_engine Lua
luajit 
libcrypto_engine_h Lua
luajit 
libcrypto_err_h Lua
luajit 
libcrypto_evp_h Lua
luajit 
libcrypto_h Lua
luajit 
libcrypto_lhash_h Lua
luajit 
libcrypto_objects_h Lua
luajit 
libcrypto_pem_h Lua
luajit 
libcrypto_pkcs7_h Lua
luajit 
libcrypto_rand_h Lua
luajit 
libcrypto_rsa_h Lua
luajit 
libcrypto_safestack_h Lua
luajit 
libcrypto_sha_h Lua
luajit 
libcrypto_types_h Lua
luajit 
libcrypto_ui_h Lua
luajit 
libcrypto_x509_h Lua
luajit 
libcrypto_x509_vfy_h Lua
luajit 
openssl Lua
openssl_h Lua
luajit 

Package:openssl
Pkg type:Lua+ffi
Version: 43e41fe
Last commit:
Author: Cosmin Apreutesei
License: Apache
Import ver: 1.1.1d

Requires: luajit 

Required by: libcurl  luasec  nginx  webb 


Top